Thursday, January 05, 2006

The WET11 bridge I bought off a guy, who sent it next day delivery, 4 months ago, turned up today.

I plugged it into my laptop, and the ethernet link came up. I did a bit of googling, and found the default ip as 192.168.1.225, and the default username/password is admin/admin.

I configured the wired interface on my laptop to 192.168.1.220, and mucked around with the routing table, since my wireless interface is on the same subnet.

I attempted to connect to it, got a login prompt, entered the username and password. It seemed to accept it, but then I was presented with a blank page.

I tried accessing it with lynx, and after logging in, I get a 404, hmm, that seems a bit strange.

I did a bit of googling, and I found a good page here, with a link to the manual, and a firmware update.

I grabbed the firmware update, great, a windows .exe, that's of great use to me, not. I tried to run it in wine, but it did nothing.

I booted up a windows machine, and attempted to copy the file off my laptop, that's when I realised I didn't have samba on my laptop. Argh.

I installed it, and restored the config file from before I installed ubuntu. I restarted it, and attempted to connect, but it wouldn't work.

I tried to query it locally, and could get nothing but "protocol negotiation failed" errors.

I went to check in the network config of ubuntu, in case it was overriding samba somehow. The network admin panel wouldn't appear.

I ran it manually, and noticed the error "(network-admin:8696): libglade-WARNING **: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory".

I did a locate, and found I did have that file, in /usr/lib/libglade/2.0. I copied it into /usr/lib, and ran it again.

This time I got "(network-admin:8778): libglade-WARNING **: Could not load support for `bonobo': libbonobo.so: cannot open shared object file: No such file or directory". That file was in there too, so I copied it across.

It didn't complain after that, but there was nothing in that application related to samba anyway.

When I tried to use the "run application" tool, I noticed the text entry box was back, it disappeared a few days ago, making it a bit useless.

I seem to be having some sort of an issue with libglade still though, because file-roller doesn't allow the ability to choose where to expand files, and crashes when you try.

In the console I saw:

(file-roller:8838): libglade-WARNING **: unknown widget class 'GtkFileChooserButton'

(file-roller:8838): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `GtkFileChooser'

(file-roller:8838): Gtk-CRITICAL **: gtk_file_chooser_set_current_folder: assertion `GTK_IS_FILE_CHOOSER (chooser)' failed

(file-roller:8838): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to `GtkFileChooser'

(file-roller:8838): Gtk-CRITICAL **: gtk_file_chooser_get_current_folder: assertion `GTK_IS_FILE_CHOOSER (chooser)' failed

great.

I dunno what to do to fix that.

So now I'm stuck with a non working samba for some reason, and a bridge with no web pages. I think I might go back to debian, where things like samba, and libraries, worked.

0 Comments:

Post a comment

<< Home